General talk

Coordinator
Nov 28, 2009 at 10:12 PM

what ever!

Nov 22, 2012 at 3:09 AM
Edited Nov 22, 2012 at 3:10 AM

Can't install.


Product Version: NetBeans IDE Dev (Build nbms-and-javadoc-9628-on-20121117)

Java: 1.7.0_09; Java HotSpot(TM) 64-Bit Server VM 23.5-b02

Runtime: Java(TM) SE Runtime Environment 1.7.0_09-b05

System: Windows 7 version 6.1 running on amd64; Cp1251; ru_RU (nb)

User directory: C:\Users\Winterwolf\AppData\Roaming\NetBeans\dev

Cache directory: C:\Users\Winterwolf\AppData\Local\NetBeans\Cache\dev


Some plugins require plugin Общий API-интерфейс языков написания сценариев (новый) to be installed.

The plugin Общий API-интерфейс языков написания сценариев (новый) is requested in implementation version 1.

The following plugin is affected:
      lsl language addon

Some plugins require plugin Editor Braces Matching to be installed.

The plugin Editor Braces Matching is requested in implementation version 200907230233.

The following plugin is affected:
      lsl language addon

Some plugins require plugin Editor Library to be installed.

The plugin Editor Library is requested in implementation version 9.

The following plugin is affected:
      lsl language addon

Some plugins require plugin API-интерфейс для MIME Lookup to be installed.

The plugin API-интерфейс для MIME Lookup is requested in implementation version 200907230233.

The following plugin is affected:
      lsl language addon

Some plugins require plugin Лексический анализатор HTML to be installed.

The plugin Лексический анализатор HTML is requested in implementation version 200907230233.

The following plugin is affected:
      lsl language addon

Some plugins require plugin Parsing API to be installed.

The plugin Parsing API is requested in implementation version 1.

The following plugin is affected:
      lsl language addon

Some plugins require plugin Системный API-интерфейс для файлов to be installed.

The plugin Системный API-интерфейс для файлов is requested in implementation version 1.

The following plugin is affected:
      lsl language addon

Some plugins require plugin API-интерфейс для систем данных to be installed.

The plugin API-интерфейс для систем данных is requested in implementation version 200907230233.

The following plugin is affected:
      lsl language addon

Some plugins require plugin API-интерфейс для узлов to be installed.

The plugin API-интерфейс для узлов is requested in implementation version 200907230233.

The following plugin is affected:
      lsl language addon

Some plugins require plugin API-интерфейс для текстовых объектов to be installed.

The plugin API-интерфейс для текстовых объектов is requested in implementation version 200907230233.

The following plugin is affected:
      lsl language addon

Some plugins require plugin API-интерфейс для служебных программ to be installed.

The plugin API-интерфейс для служебных программ is requested in implementation version 1.

The following plugin is affected:
      lsl language addon

Some plugins require plugin Системный API-интерфейс для окон to be installed.

The plugin Системный API-интерфейс для окон is requested in implementation version 200907230233.

The following plugin is affected:
      lsl language addon

Some plugins not installed to avoid potential installation problems.

Jan 25, 2014 at 11:05 AM
I experimented the same problem.
I was searching the whole NetBeans Plugin Database up and down and was unable to find it.
But I found that the same problem is happening to another Scripting Language Plugin

http://plugins.netbeans.org/plugin/36598/nbscala-2-8-x
http://forums.netbeans.org/post-17178.html

but now it has an plugin update.

http://plugins.netbeans.org/plugin/52559/nbscala-1-6-2-1

So I think the plugin does not work anymore with new NetBeans Versions and needs a complete review and update to the new NetBeans that has all these Plugins integrated into it's code base.

NetBeans 7.4 is reporting this unresolvable conflict on dependencies:

Some plugins require plugin Common Scripting Language API (new) to be installed.
The plugin Common Scripting Language API (new) is requested in implementation version 1. The following plugin is affected:       lsl language addon
Some plugins require plugin Editor Braces Matching to be installed.
The plugin Editor Braces Matching is requested in implementation version 200907230233. The following plugin is affected:       lsl language addon
Some plugins require plugin Editor Library to be installed.
The plugin Editor Library is requested in implementation version 9. The following plugin is affected:       lsl language addon
Some plugins require plugin MIME Lookup API to be installed.
The plugin MIME Lookup API is requested in implementation version 200907230233. The following plugin is affected:       lsl language addon
Some plugins require plugin HTML Lexer to be installed.
The plugin HTML Lexer is requested in implementation version 200907230233. The following plugin is affected:       lsl language addon
Some plugins require plugin Parsing API to be installed.
The plugin Parsing API is requested in implementation version 1. The following plugin is affected:       lsl language addon
Some plugins require plugin File System API to be installed.
The plugin File System API is requested in implementation version 1. The following plugin is affected:       lsl language addon
Some plugins require plugin Datasystems API to be installed.
The plugin Datasystems API is requested in implementation version 200907230233. The following plugin is affected:       lsl language addon
Some plugins require plugin Nodes API to be installed.
The plugin Nodes API is requested in implementation version 200907230233. The following plugin is affected:       lsl language addon
Some plugins require plugin Text API to be installed.
The plugin Text API is requested in implementation version 200907230233. The following plugin is affected:       lsl language addon
Some plugins require plugin Utilities API to be installed.
The plugin Utilities API is requested in implementation version 1. The following plugin is affected:       lsl language addon
Some plugins require plugin Window System API to be installed.
The plugin Window System API is requested in implementation version 200907230233. The following plugin is affected:       lsl language addon Some plugins not installed to avoid potential installation problems.